vPC Configuration – Cisco Port Channels and vPCs

vPC Configuration

Configuring a basic vPC is a multistep process. The following are the steps to enable a basic vPC configuration on the Cisco Nexus 7000 or 9000 Series switch:

Step 1. Enter the global configuration mode.

Step 2. Enable the vPC feature.

Step 3. Create a vPC domain and enter the vPC domain mode.

Step 4. Configure the vPC peer-keepalive link.

Step 5. Create the vPC peer-link.

Step 6. Create a port channel and configure it as a vPC.

From the global configuration mode, you must enable the vPC feature before you can configure and use vPCs. The next step is to create a vPC domain. Use a unique vPC domain number throughout a single vPC domain. This domain ID is used to automatically form the vPC system MAC address. You can then configure the destination IP for the peer-keepalive link that carries the keepalive messages. Once the vPC peer-keepalive link is configured, you can create the vPC peer-link by designating the port channel you want on each device as the vPC peer-link for the specified vPC domain. Once the vPC peer-link is configured, you can connect the downstream device. You create a port channel from the downstream device to the primary and secondary vPC peer devices. On each vPC peer device, you assign a vPC number to the port channel that connects to the downstream device.

Table 4-3 summarizes the NX-OS CLI commands related to basic vPC configuration and verification.

   

Table 4-3 Summary of NX-OS CLI Commands for vPC Configuration and Verification

Command

Purpose

configure terminalEnters global configuration mode.

[
no

feature vpc
Enables vPCs on the device.

[
no

feature lacp
Enables LACP on the device.

vrf context
 
vrf-name

Creates a new VRF and enters VRF configuration mode. The
vrf-name
 can be any case-sensitive, alphanumeric string up to 32 characters.
interface
 
interface-type slot/port

Enters interface configuration mode.

no switchport

Configures the interface as a Layer 3 interface.

vrf member
 
vrf-name

Adds this interface to a VRF.

ip address 
ip-prefix/length

Configures an IP address for this interface. You must do this step after you assign this interface to a VRF.

switchport mode
 
trunk

Sets the interface as a Layer 2 trunk port. A trunk port can carry traffic in one or more VLANs on the same physical link.

channel-group
 
channel-number
 [
force
] [
mode
 {
on
 |
active
 |
passive
}]

Configures the port in a channel group and sets the mode. The
channel-number
 range is from 1 to 4096. This command creates the port channel associated with this channel group, if the port channel does not already exist. All static port channel interfaces are set to mode on. You must set all LACP-enabled port channel interfaces to active or passive. The default mode is on.

 vpc domain
 
domain-id

Creates a vPC domain if it does not already exist, and enters the
vpc domain
 configuration mode. There is no default; the range is from 1 to 1000.
peer-keepalive destination
 
ipaddress
source
ipaddress
 |
vrf{name|managementvpckeepalive}

Configures the IPv4 and IPv6 addresses for the remote end of the vPC peer-keepalive link.

interface port-channel
 
channel-number

Selects the port channel and enters interface configuration mode.

vpc peer-link

Configures the selected port channel as the vPC peer-link.

vpc
 
number

Configures the selected port channel into the vPC to connect to the downstream device. The range is from 1 and 4096.

Note
 The vPC number you assign to the port channel connecting to the downstream device from the vPC peer device must be identical on both vPC peer devices.

show cdp neighbors {device-id | interface
 
interface-type slot/port
} [
detail
]

Displays the CDP neighbor status.

show port-channel summary

Displays information about the port channel.

show vpc

Displays information about each vPC domain.

show vpc brief

Displays brief information about each vPC domain.

show vpc role

Displays the peer status, role of the local device, vPC system MAC address and system priority, and MAC address and priority for the local vPC device.

show vpc peer-keepalive

Displays information about the peer-keepalive messages.

show vpc statistics

Displays statistics about the vPCs.

show vpc consistency-parameters

Displays the status of those parameters that must be consistent across all vPC interfaces.

show running-config vpc

Displays running configuration information for vPCs.

Examples 4-1 to 4-3 show the basic vPC configuration and verification on the sample topology shown in Figure 4-14. Layer 3 connectivity between N7K-A and N7K-B and N9K-A is established in the backend. In this example, we will focus only on vPC configuration and verification. We will configure N7K-A and N7K-B as vPC peers in vPC domain 11. We will configure the link connecting the interface Ethernet 3/25 on both vPC peers as a vPC peer-keepalive link. We will also configure the link connecting the interfaces Ethernet 3/26 and Ethernet 3/31 in the port channel on both vPC peers and configure
it as vPC peer-link. vPC 10 will be set up toward N9K-A on the interfaces shown in Figure 4-14.

  

Figure 4-14 Sample Topology for vPC Configuration and Verification

In Example 4-1, we will do some pre-configuration, such as setting up the Layer 3 link between vPC peers to be later utilized as a vPC keepalive link and setting up a port channel between vPC peers to be later utilized as a vPC peer-link during vPC configuration.

Example 4-1 Preparing for vPC

Click here to view code image


! Verifying the physical connectivity between N7K-A, N7K-B and N9K-A.
N7K-A
N7K-A#
show cdp neighbors
Capability Codes: R – Router, T – Trans-Bridge, B – Source-Route-Bridge
                  S – Switch, H – Host, I – IGMP, r – Repeater,
                  V – VoIP-Phone, D – Remotely-Managed-Device,
                  s – Supports-STP-Dispute

Device-ID          Local Intrfce  Hldtme Capability  Platform        Port ID
N7K-B(JAF1752AKJA)
Eth3/25
        171     R S I s    N7K-C7009       Eth3/25
N7K-B(JAF1752AKJA)
Eth3/26
        172     R S I s    N7K-C7009       Eth3/26
N7K-B(JAF1752AKJA)
Eth3/31
        173     R S I s    N7K-C7009       Eth3/31
N9K-A(FDO241519JZ)   
Eth6/8
         176     R S I s    N9K-C93180YC-FX Eth1/49
Total entries displayed: 4

N7K-B
N7K-B#
show cdp neighbors

Capability Codes: R – Router, T – Trans-Bridge, B – Source-Route-Bridge
                  S – Switch, H – Host, I – IGMP, r – Repeater,
                  V – VoIP-Phone, D – Remotely-Managed-Device,
                  s – Supports-STP-Dispute

Device-ID          Local Intrfce  Hldtme Capability  Platform        Port ID
N7K-A(JAF1752AKGC)
                    
Eth3/25
        174    R S I s    N7K-C7009       Eth3/25
N7K-A(JAF1752AKGC)       
Eth3/26
        174    R S I s    N7K-C7009       Eth3/26
N7K-A(JAF1752AKGC)     
Eth3/31
        175    R S I s    N7K-C7009       Eth3/31
N9K-A(FDO241519JZ) 
Eth6/8
         154    R S I s    N9K-C93180YC-FX Eth1/50

Total entries displayed: 4

N9K-A

N9K-A#
show cdp neighbors
Capability Codes: R – Router, T – Trans-Bridge, B – Source-Route-Bridge
                  S – Switch, H – Host, I – IGMP, r – Repeater,
                  V – VoIP-Phone, D – Remotely-Managed-Device,
                  s – Supports-STP-Dispute
Device-ID          Local Intrfce  Hldtme  Capability  Platform          Port ID
N7K-A(JAF1752AKGC)
              
Eth1/49
        138     R S I s    N7K-C7009         Eth6/8
N7K-B(JAF1752AKJA)
Eth1/50
        174     R S I s    N7K-C7009         Eth6/8
Total entries displayed: 2

! Configuring the Layer 3 link between N7K-A and N7K-B and making it ready to be

later used as vPC Peer-Keepalive link. We will configure this link in vrf VPC-KEEPALIVE

and make sure the end-to-end connectivity between vPC peers N7K-A and N7K-B

is established via this link.


N7K-A
N7K-A#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
N7K-A(config)#
vrf context VPC-KEEPALIVE
N7K-A(config-vrf)#
interface Ethernet 3/25
N7K-A(config-if)#
no switchport
N7K-A(config-if)#
vrf member VPC-KEEPALIVE
Warning: Deleted all L3 config on interface Ethernet3/25
N7K-A(config-if)#
ip address 10.1.1.10/24
N7K-A(config-if)#
end
N7K-A#
N7K-B
N7K-B#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
N7K-B(config)#
vrf context VPC-KEEPALIVE
N7K-B(config-vrf)#
interface Ethernet 3/25
N7K-B(config-if)#
no switchport
N7K-B(config-if)#
vrf member VPC-KEEPALIVE
Warning: Deleted all L3 config on interface Ethernet3/25
N7K-B(config-if)#
ip address 10.1.1.20/24
N7K-B(config-if)#
end
N7K-B#
! Verifying end-to-end connectivity across newly created Layer 3 link.


N7K-A
N7K-A#
ping 10.1.1.20 vrf VPC-KEEPALIVE
PING 10.1.1.20 (10.1.1.20): 56 data bytes
64 bytes from 10.1.1.20: icmp_seq=0 ttl=254 time=1.349 ms
64 bytes from 10.1.1.20: icmp_seq=1 ttl=254 time=0.916 ms
64 bytes from 10.1.1.20: icmp_seq=2 ttl=254 time=0.923 ms
64 bytes from 10.1.1.20: icmp_seq=3 ttl=254 time=0.866 ms
64 bytes from 10.1.1.20: icmp_seq=4 ttl=254 time=0.91 ms
— 10.1.1.20 ping statistics —
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.866/0.992/1.349 ms


N7K-B
N7K-B#
ping 10.1.1.10 vrf VPC-KEEPALIVE

PING 10.1.1.10 (10.1.1.10): 56 data bytes
64 bytes from 10.1.1.10: icmp_seq=0 ttl=254 time=1.334 ms
64 bytes from 10.1.1.10: icmp_seq=1 ttl=254 time=0.902 ms
64 bytes from 10.1.1.10: icmp_seq=2 ttl=254 time=0.876 ms
64 bytes from 10.1.1.10: icmp_seq=3 ttl=254 time=0.903 ms
64 bytes from 10.1.1.10: icmp_seq=4 ttl=254 time=0.858 ms
— 10.1.1.10 ping statistics —
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.858/0.974/1.334 ms

! Configuring Port-Channel 1 between N7K-A and N7K-B using links Ethernet 3/26 and
Ethernet 3/31 and making it ready to be later used as vPC Peer-Link. Although the
channel group number can be any value between 1 and 4096, matching the port channel
number of vPC Peer-Link with the vPC domain number may help with troubleshooting.
In this exercise, the same number is not used to demonstrate that it is not
required for configuring the vPC domain.



N7K-A
N7K-A(config)#
interface Ethernet 3/26, Ethernet 3/31
N7K-A(config-if-range)#
switchport
N7K-A(config-if-range)#
switchport mode trunk
N7K-A(config-if-range)#
channel-group 1
N7K-A(config-if-range)#
end


N7K-B
N7K-B(config)#
interface Ethernet 3/26, Ethernet 3/31

N7K-B(config-if-range)#
switchport
N7K-B(config-if-range)#
switchport mode trunk
N7K-B(config-if-range)#
channel-group 1
N7K-B(config-if-range)#
end


! Verifying the newly created Layer 2 Port-Channel. The flags next to the interfaces
are described by the legend at the beginning of the command output. The interface
port-channel 1 is switched port (S) and is up (U), its member ports are flagged
with (P).


N7K-A
N7K-A#
show port-channel summary
Flags:  D – Down        P – Up in port-channel (members)
        I – Individual  H – Hot-standby (LACP only)
        s – Suspended   r – Module-removed
        b – BFD Session Wait
        S – Switched    R – Routed
        U – Up (port-channel)
        M – Not in use. Min-links not met
——————————————————————————–
Group Port-      Type    Protocol  Member Ports
      Channel
——————————————————————————–
1     
Po1(SU)
    Eth     NONE      
Eth3/26(P)  Eth3/31(P)


N7K-B
N7K-B#
show port-channel summary
Flags:  D – Down        P – Up in port-channel (members)
        I – Individual  H – Hot-standby (LACP only)
        s – Suspended   r – Module-removed
        b – BFD Session Wait
        S – Switched    R – Routed
        U – Up (port-channel)
        M – Not in use. Min-links not met
——————————————————————————–
Group Port-      Type    Protocol  Member Ports
      Channel
——————————————————————————–
1     
Po1(SU)
    Eth     NONE      
Eth3/26(P)  Eth3/31(P)

In Example 4-2, we configure vPC 10 toward the N9K-A switch.

Example 4-2 vPC Configuration

Click here to view code image
! Entering global configuration and enabling the vPC feature.


N7K-A
N7K-A#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
N7K-A(config)#
feature vpc

N7K-A(config)#
N7K-B
N7K-B#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
N7K-B(config)#
feature vpc
N7K-B(config)#
! Configuring the vPC domain 11 for the vPC and configuring the vPC peer-keepalive
link.


N7K-A
N7K-A(config)#
vpc domain 11
N7K-A(config-vpc-domain)#
peer-keepalive destination 10.1.1.20 source 10.1.1.10 vrf
VPC-KEEPALIVE
N7K-A(config-vpc-domain)#
exit
N7K-A(config)#


N7K-B
N7K-B(config)#
vpc domain 11

N7K-B(config-vpc-domain)#
peer-keepalive destination 10.1.1.10 source 10.1.1.20 vrf

VPC-KEEPALIVE

N7K-B(config-vpc-domain)#
exit
N7K-B(config)#
! Configuring the vPC Peer-Link


N7K-A
N7K-A(config)#
interface port-channel 1

N7K-A(config-if)#
vpc peer-link

Warning:
Ensure that VPC peer-link member ports on both peers use identical VDC types (limit
resource module-type VDC config command).
Please note that spanning tree port type is changed to “network” port type on vPC
peer-link.
This will enable spanning tree Bridge Assurance on vPC peer-link provided the STP
Bridge Assurance (which is enabled by default) is not disabled.
N7K-A(config-if)#
exit

N7K-A(config)#



N7K-B
N7K-B(config)#
interface port-channel 1

N7K-B(config-if)#
vpc peer-link

Warning:
Ensure that VPC peer-link member ports on both peers use identical VDC types (limit
resource module-type VDC config command).
Please note that spanning tree port type is changed to “network” port type on vPC
peer-link.
This will enable spanning tree Bridge Assurance on vPC peer-link provided the STP
Bridge Assurance (which is enabled by default) is not disabled.
N7K-B(config-if)#
exit

N7K-B(config)#


! Configuring vPC Member Ports on vPC peers N7K-A and N7K-B. First, we will enable
LACP feature and configure the member ports on Port-Channel 10.


N7K-A
N7K-A(config)#
feature lacp
N7K-A(config)#
interface Ethernet 6/8
N7K-A(config-if)#
channel-group 10 mode active
N7K-A(config-if)#
interface port-channel 10
N7K-A(config-if)#
vpc 10

N7K-A(config-if)#
end
N7K-A#

N7K-B
N7K-B(config)#
feature lacp

N7K-B(config)#
interface Ethernet 6/8
N7K-B(config-if)#
channel-group 10 mode active
N7K-B(config-if)#
interface port-channel 10
N7K-B(config-if)#
vpc 10
N7K-B(config-if)#
end

N7K-B#

! Configuring upstream port-channel 15 on N9K-A and verifying that the port-channel
is UP and working. Although the channel group number can be any value between 1 and
4096, matching the downstream device port channel number with the vPC number may
help with troubleshooting. In this exercise, the same number is not used to demonstrate
that it is not a requirement.



N9K-A
N9K-A#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
N9K-A(config)#
feature lacp
N9K-A(config)#
interface Ethernet 1/49-50
N9K-A(config-if-range)#
channel-group 15 mode active
N9K-A(config-if-range)#
end


N9K-A#
show port-channel summary
Flags:  D – Down        P – Up in port-channel (members)
        I – Individual  H – Hot-standby (LACP only)
        s – Suspended   r – Module-removed
        b – BFD Session Wait
        S – Switched    R – Routed
        U – Up (port-channel)
        p – Up in delay-lacp mode (member)
        M – Not in use. Min-links not met
——————————————————————————–
Group Port-      Type    Protocol  Member Ports
      Channel
——————————————————————————–
15    
Po15(SU)
   Eth     LACP      
Eth1/49(P)  Eth1/50(P)

N9K-A#

In Example 4-3, we perform vPC verification on N7K-A.

Example 4-3 vPC Verification on N7K-A

Click here to view code image


! Verifying the vPC.
N7K-A#
show vpc
Legend:
                (*) – local vPC is down, forwarding via vPC peer-link

vPC domain id                          : 11
Peer status                            : peer adjacency formed ok
vPC keep-alive status                  : peer is alive

Configuration consistency status       : success
Per-vlan consistency status            : success
Type-2 consistency status              : success
vPC role                               : primary

Number of vPCs configured              : 1
Peer Gateway                           : Disabled
Dual-active excluded VLANs and BDs     : –
Graceful Consistency Check             : Enabled
Auto-recovery status                   : Enabled, timer is off.(timeout = 240s)
Delay-restore orphan ports status      : Timer is off.(timeout = 0s)
Operational Layer3 Peer-router         : Disabled
Self-isolation                         : Disabled

vPC Peer-link status

——————————————————————————–
id   Port    Status Active vlans                  Active BDs
—   —-    —— ————————————————————-
1    
Po1     up
     1,200                         –
vPC status
Id               : 10
Port            : Po10
Status          : up
  Consistency     : success
  Reason          : success
  Active Vlans    : 1,200

! Verifying vPC details in brief format.
N7K-A#
show vpc brief
Legend:
                (*) – local vPC is down, forwarding via vPC peer-link

vPC domain id                          : 11
Peer status                            : peer adjacency formed ok
vPC keep-alive status                  : peer is alive
Configuration consistency status       : success
Per-vlan consistency status            : success
Type-2 consistency status              : success
vPC role                               : primary
Number of vPCs configured              : 1
Peer Gateway                           : Disabled
Dual-active excluded VLANs and BDs     : –
Graceful Consistency Check             : Enabled
Auto-recovery status                   : Enabled, timer is off.(timeout = 240s)
Delay-restore status                   : Timer is off.(timeout = 30s)
Delay-restore SVI status               : Timer is off.(timeout = 10s)
Delay-restore orphan ports status      : Timer is off.(timeout = 0s)
Operational Layer3 Peer-router         : Disabled
Self-isolation : Disabled

vPC Peer-link status
——————————————————————————–
id    Port    Status Active vlans            Active BDs
—    —-    —— ————————————————————-
1     
Po1     up
     1,200 –
vPC status
—————————————————–
id    Port         Status Consistency Active VLANs
—– ———— —— ———– —————-
10    Po10         up
     success     1,200
! Verifying vPC role of vPC peers. The show vpc role command also shows the vPC
system-mac created from vPC domain ID. The last octet (0b, or decimal 11) is
derived from the vPC domain ID 11.
N7K-A#
show vpc role

vPC Role status
—————————————————-
vPC role                        : primary
vPC system-mac                  : 00:23:04:ee:be:0b
vPC system-priority             : 32667
vPC local system-mac            : e4:c7:22:15:2c:45
vPC local role-priority         : 32667
vPC peer system-mac             : e4:c7:22:15:33:c5
vPC peer role-priority          : 32667

! Verifying vPC peer-keepalive link details.
N7K-A#
show vpc peer-keepalive
vPC keep-alive status           : peer is alive

–Peer is alive for             : (2658) seconds, (484) msec
–Send status                   : Success
–Last send at                  : 2022.02.17 20:18:33 495 ms
–Sent on interface             : Eth3/25
–Receive status                : Success
–Last receive at               : 2022.02.17 20:18:33 495 ms
–Received on interface         : Eth3/25
–Last update from peer         : (0) seconds, (854) msec

vPC Keep-alive parameters

Destination                   : 10.1.1.20
–Keepalive interval            : 1000 msec
–Keepalive timeout             : 5 seconds
–Keepalive hold timeout        : 3 seconds

Keepalive vrf                 : VPC-KEEPALIVE
–Keepalive udp port            : 3200
–Keepalive tos                 : 192

! Verifying vPC peer keepalive statistics.
N7K-A#
show vpc statistics peer-keepalive
vPC keep-alive statistics
—————————————————-
peer-keepalive tx count:          2888
peer-keepalive rx count:          2843
average interval for peer rx:     992
Count of peer state changes:      0
! Verifying vPC Peer-Link statistics.

N7K-A#
show vpc statistics peer-link
port-channel1 is up
admin state is up
  Hardware: Port-Channel, address: b0aa.771c.c991 (bia b0aa.771c.c991)
  MTU 9216 bytes, BW 20000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, medium is broadcast
  Port mode is trunk
  full-duplex, 10 Gb/s
  Input flow-control is off, output flow-control is off
  Auto-mdix is turned off
  Switchport monitor is off
  EtherType is 0x8100
  
Members in this channel: Eth3/26, Eth3/31
  Last clearing of “show interface” counters never
  4 interface resets
  Load-Interval #1: 30 seconds
    30 seconds input rate 2192 bits/sec, 2 packets/sec
    30 seconds output rate 904 bits/sec, 1 packets/sec
    input rate 2.19 Kbps, 2 pps; output rate 904 bps, 1 pps
  Load-Interval #2: 5 minute (300 seconds)
    300 seconds input rate 2184 bits/sec, 1 packets/sec
    300 seconds output rate 920 bits/sec, 1 packets/sec
    input rate 2.18 Kbps, 1 pps; output rate 920 bps, 1 pps
  
RX

48 unicast packets 3192 multicast packets 0 broadcast packets
3208 input packets 2850183 bytes
    23 jumbo packets 0 storm suppression packets
    0 runts 0 giants 14 CRC/FCS 0 no buffer
    14 input error 0 short frame 0 overrun 0 underrun 0 ignored
    0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
    0 input with dribble 0 input discard
    0 Rx pause
TX
48 unicast packets 3587 multicast packets 2 broadcast packets
3587 output packets 364772 bytes

    7 jumbo packets
    0 output error 0 collision 0 deferred 0 late collision
    0 lost carrier 0 no carrier 0 babble 0 output discard
    0 Tx pause

! Verifying newly created vPC 10 statistics.
N7K-A#
show vpc statistics vpc 10
port-channel10 is up
admin state is up

 vPC Status: Up, vPC number: 10
  Hardware: Port-Channel, address: 308b.b2d8.432c (bia 308b.b2d8.432c)
  MTU 1500 bytes, BW 40000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, medium is broadcast
  Port mode is trunk
  full-duplex, 40 Gb/s
  Input flow-control is off, output flow-control is off
  Auto-mdix is turned off
  Switchport monitor is off
  EtherType is 0x8100
  Members in this channel: Eth6/8
  Last clearing of “show interface” counters never
  1 interface resets
  Load-Interval #1: 30 seconds
    30 seconds input rate 80 bits/sec, 0 packets/sec
    30 seconds output rate 16 bits/sec, 0 packets/sec
    input rate 80 bps, 0 pps; output rate 16 bps, 0 pps
  Load-Interval #2: 5 minute (300 seconds)
    300 seconds input rate 136 bits/sec, 0 packets/sec
    300 seconds output rate 144 bits/sec, 0 packets/sec
    input rate 136 bps, 0 pps; output rate 144 bps, 0 pps
  
RX
292 unicast packets 741 multicast packets 4 broadcast packets
745 input packets 70652 bytes
    0 jumbo packets 0 storm suppression packets
    0 runts 0 giants 0 CRC/FCS 0 no buffer
    0 input error 0 short frame 0 overrun 0 underrun 0 ignored
    0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
    0 input with dribble 0 input discard
    0 Rx pause
  
TX
292 unicast packets 145 multicast packets 0 broadcast packets
145 output packets 32776 bytes
    0 jumbo packets
    0 output error 0 collision 0 deferred 0 late collision
    0 lost carrier 0 no carrier 0 babble 0 output discard
    0 Tx pause
! Verifying vPC global consistency parameters.
N7K-A#
show vpc consistency-parameters global
    Legend:
        Type 1 : vPC will be suspended in case of mismatch

Name                        Type  Local Value             Peer Value
————-               —-  ———————-  ———————–
STP MST Simulate PVST       1      Enabled                 Enabled
STP Port Type, Edge         1      Normal, Disabled,       Normal, Disabled,
BPDUFilter, Edge BPDUGuard         Disabled                Disabled
STP MST Region Name         1      “”                      “”
STP Disabled                1      None                    None
STP Mode                    1      Rapid-PVST              Rapid-PVST
STP Bridge Assurance        1      Enabled                 Enabled
STP Loopguard               1      Disabled                Disabled
STP MST Region Instance to  1
 VLAN Mapping
STP MST Region Revision     1      0                        0
Interface-vlan admin up     2      200                      200
Interface-vlan routing      2      1,200                    1,200
capability
Allowed VLANs               –      1,200                    1,200
Local error VLANs           –      –                        –

! Verifying newly created vPC 10 consistency parameters.
N7K-A#
show vpc consistency-parameters vpc 10
    Legend:
        Type 1 : vPC will be suspended in case of mismatch

Name                        Type  Local Value             Peer Value
————-               —-  ———————-  ———————–
Interface type              1     port-channel            port-channel
LACP Mode                   1     on                      on
STP Port Guard              1     Default                 Default
STP Port Type               1     Default                 Default
Speed                       1     40 Gb/s                 40 Gb/s
Duplex                      1     full                    full
MTU                         1     1500                    1500
Vlan xlt mapping            1     Enabled                 Enabled
Port Mode                   1     trunk                   trunk
STP MST Simulate PVST       1     Default                 Default
Native Vlan                 1     1                       1
Admin port mode             1     trunk                   trunk
lag-id                      1     [(7f9b,                 [(7f9b,
                                  0-23-4-ee-be-b, 800a,   0-23-4-ee-be-b, 800a,
                                  0, 0), (8000,           0, 0), (8000,
                                  ac-4a-67-43-15-a7, e,   ac-4a-67-43-15-a7, e,
                                  0, 0)]                  0, 0)]
mode                        1     active                  active
vPC card type               1     F3                      F3
Allowed VLANs               –     1,200                   1,200
Local error VLANs           –     –                       –
! Verifying vPC related running-configuration on the device.

N7K-A#
show running-config vpc
!Command: show running-config vpc
!Running configuration last done at: Thu Feb 17 20:09:58 2022
!Time: Thu Feb 17 20:22:41 2022
version 8.4(2)
feature vpc
vpc domain 113
  peer-keepalive destination 10.1.1.20 source 10.1.1.10 vrf VPC-KEEPALIVE
interface port-channel1
  vpc peer-link
interface port-channel10
  vpc 10
N7K-A#

Similar verification can be done on N7K-B.

Leave a Comment